Groovy 1.7 vers 1.8

Publié le par Séverine

J'ai voulu installer le nouveau groovy 1.8 sous IntelliJ IDEA :

 

Je télécharge les nouvelles libs, les nouveaux sources.

Je mets à jour ma librairy groovy dans mon project settings.

Je lance mes tests et là ... grosse erreur :

 

NoClassDefFoundError: org/codehaus/groovy/transform/powerassert/ValueRecorder

 

Alors, en fait, c'est juste que maintenant ValueRecorder a bougé entre les deux versions de groovy et qu'il fallait que je refasse un clean de mon projet ! Il cherchait ValueRacorder au mauvais endroit ! A ben oui, c'est ballot !

 

En plus, dans notre système de build, j'avais oublié de mettre à jour la librairie qui se trouve dans groovy-1.8.0/embeddable/groovy-all-1.8.0.jar. C'est cette librairie qui nous permet de compiler tout notre code avec groovyc.

 

Publié dans groovy

Pour être informé des derniers articles, inscrivez vous :
Commenter cet article